Service creation issue in AKS EastUS2 (Virginia) Public Region

Incident Report for Solace Cloud

Update

All existing services in the AKS EastUS2 (Virginia) Public Region are currently functioning normally. Service creation in this region has been temporarily disabled while we continue to work with Azure engineering on a resolution. We expect to provide a further update by Monday (EST).
Posted Apr 26, 2026 - 00:45 EDT

Identified

Azure engineering has determined that the root cause is a networking issue where traffic is not reaching the Kubernetes control plane, and they are actively working on a resolution.
Posted Apr 24, 2026 - 15:49 EDT

Investigating

We are currently investigating Service creation failures and node scaling issues in the AKS EastUS2 (Virginia) Public Region, caused by an issue with the Kubernetes API endpoint, in collaboration with Azure support to identify the root cause and resolution.
Posted Apr 24, 2026 - 04:45 EDT
This incident affects: Mission Control - Azure Regions (Azure - East US 2 (Virginia)).